Расчет показателей экономической эффективности

Сумма = Цена * Количество;

глРассчитатьНалогиПриходногоДокумента(Контекст);

КонецЕсли;

КонецПроцедуры //Обработка подбора

//************************************************************

Процедура ПодборПоПрайсЛисту(ФлВыбиратьПрайсЛист=0)

ПрайсЛист=ВосстановитьЗначение("ПрайсЛист");

Если (ФлВыбиратьПрайсЛист = 1) Или (ПустоеЗначение(ПрайсЛист) = 1) Тогда

СписокКаталоговДляВыбора=СоздатьОбъект("СписокЗначений");

СписокКаталоговДляВыбора.ДобавитьЗначение("По справочнику 'Прайс-лист'");

СпрКаталогов=СоздатьОбъект("Справочник.Каталоги");

СпрКаталогов.ВыбратьЭлементы();

Пока СпрКаталогов.ПолучитьЭлемент() = 1 Цикл

Если СпрКаталогов.ЭтоГруппа() = 1 Тогда Продолжить КонецЕсли;

СписокКаталоговДляВыбора.ДобавитьЗначение(СпрКаталогов.ТекущийЭлемент());

КонецЦикла;

Зн = ""; Поз = "";

Если СписокКаталоговДляВыбора.ВыбратьЗначение(Зн, "", Поз,,1) = 0 Тогда

Возврат КонецЕсли;

ПрайсЛист=СписокКаталоговДляВыбора.ПолучитьЗначение(Поз);

СохранитьЗначение("ПрайсЛист", ПрайсЛист);

КонецЕсли;

Если ПрайсЛист = "По справочнику 'Прайс-лист'" Тогда

глПодбор(Контекст, "прайс_лист", "ДляПодбора");

Иначе

СписокПараметров=СоздатьОбъект("СписокЗначений");

СписокПараметров.ДобавитьЗначение(ПрайсЛист, "Каталог");

ОткрытьПодбор("Обработка.РаботаСКаталогомXML",,СписокПараметров, 1);

КонецЕсли;

КонецПроцедуры

//*************************************************************Процедура ПриЗаписи() //Предопределенная процедура

Если глМожноЗаписатьДокумент(Контекст)=0 Тогда

СтатусВозврата(0);

ИначеЕсли глКонтрольДатыДокумента(Контекст, НачальнаяДатаДокумента)=1 Тогда

СтатусВозврата(0);

КонецЕсли;

КонецПроцедуры// ПриЗаписи

//************************************************************

Процедура ПриЗакрытии() //Предопределенная процедура

КонецПроцедуры// ПриЗакрытии

//************************************************************

//Инициализирум список действий по кнопке "Действия"

СписокДействий = СоздатьОбъект("СписокЗначений");

СписокДействий.ДобавитьЗначение("Структура подчиненности");

СписокДействий.ДобавитьЗначение("Отчет о движениях документа");

//СписокДействий.ДобавитьЗначение("Отчет о бухгалтерских проводках");

СписокДействий.ДобавитьЗначение("Обновление цен в справочнике");

СписокДействий.ДобавитьЗначение("Ввести на основании");

СписокДействий.ДобавитьЗначение("Открыть в журнале");

СписокДействий.ДобавитьЗначение("Выгрузить (отправить по эл.почте)").

Перейти на страницу: 2 3 4 5 6 7 

Другое по экономике

Анализ ликвидности и платежеспособности предприятия ООО Прогресс
В условиях рыночной экономики от предприятий требуется повышение эффективности производства, конкурентоспособности продукции и услуг на основе внедрения достижений научно-технического прогресса, эффективных форм хозяйствования и управления производством, преодоления бес ...