Расчет показателей экономической эффективности

Предупреждение("Документ """ + ПредставлениеВида() + """ не вводят на основании других документов!");

СтатусВозврата(0);

КонецПроцедуры// ВводНаОсновании

//************************************************************

Процедура ПриОткрытии() // Предопределенная процедура

Парам = Форма.Параметр;

Если Лев(Парам, 13) = "ПЕЧАТЬСПРОСМ_" Тогда

Печать();

СтатусВозврата(0);

Возврат;

КонецЕсли;

НачальнаяДатаДокумента = ДатаДок;

Форма.Товар.ВыполнятьФормулуТолькоПриИзменении(1);

Форма.Количество.ВыполнятьФормулуТолькоПриИзменении(1);

Форма.Цена.ВыполнятьФормулуТолькоПриИзменении(1);

Форма.Сумма.ВыполнятьФормулуТолькоПриИзменении(1);

Форма.НДС.ВыполнятьФормулуТолькоПриИзменении(1);

Форма.СтавкаНДС.ВыполнятьФормулуТолькоПриИзменении(1);

Форма.СуммаНП.ВыполнятьФормулуТолькоПриИзменении(1);

Форма.СтавкаНП.ВыполнятьФормулуТолькоПриИзменении(1);

глПроверкаРазрешенияРедактирования(Контекст);

// Если открыли только на просмотр, то надо кнопки сделать недоступными

Если Форма.ТолькоПросмотр() = 1 Тогда

Форма.КнФирма.Доступность(0);

Форма.КнОснование.Доступность(0);

Форма.КнОплата.Доступность(0);

Форма.кнПодборПоКаталогу.Доступность(0);

Форма.кнПодборПоПрайсу.Доступность(0);

Форма.кнИзменить.Доступность(0);

Форма.кнЗаполнить.Доступность(0);

Форма.КнЗаписать.Доступность(0);

Форма.КнПровести.Доступность(0);

Форма.ОК.Доступность(0);

Форма.КнопкаПоУмолчанию("Закрыть");

Иначе

Форма.КнопкаПоУмолчанию("ОК");

КонецЕсли;

ОбновитьНадписи();

ИспользоватьИнформациюОцене();

СтараяДата= ДатаДок;

СтарыйКлиент= Клиент;

КонецПроцедуры

//************************************************************

Процедура ОбработкаПодбора(Выб, гКонтекстФормыПодбора)

ЗаголовокФормыПодбора = гКонтекстФормыПодбора.Форма.Заголовок();

Если Найти(ЗаголовокФормыПодбора, " (владелец - ") = 0 Тогда

глПриОбработкеПодбора(Выб, Контекст);

Иначе

СписокПараметровЦены=ПолучитьЗначениеИзПодбора("ОписаниеЦены()");

_цена=СписокПараметровЦены.Получить("Цена");

_валюта=СписокПараметровЦены.Получить("Валюта");

_единица=СписокПараметровЦены.Получить("Единица");

// пересчитаем цену в валюту документа

_цена = глПересчет(_цена, _валюта, Дата_Курса, Валюта, Курс);

Колво=1;

Если Константа.ЗапрашиватьКоличество = Да Тогда

Если ВвестиЧисло(Колво, "Количество товара """ + Выб + """", 10, 3) = 0 Тогда Возврат КонецЕсли;

КонецЕсли;

ВыбратьСтроки();

Пока ПолучитьСтроку() = 1 Цикл

Если Товар = Выб Тогда

Количество=Количество + Колво;

Цена = глСуммаПриходногоДокумента(ВариантРасчетаНалогов, Цена, 1, Товар.СтавкаНДС.Получить(ДатаДок), Товар, ДатаДок);

Сумма = Цена * Количество;

глРассчитатьНалогиПриходногоДокумента(Контекст);

Возврат;

КонецЕсли;

КонецЦикла;

НоваяСтрока();

Товар=Выб;

Количество=Колво;

Единица=_единица;

Цена=_цена;

Коэффициент=_единица.Коэффициент;

Если ВариантРасчетаНалогов.СтавкаНДСизНоменклатуры = 1 Тогда

СтавкаНДС = Товар.СтавкаНДС.Получить(ДатаДок);

Иначе

СтавкаНДС = ВариантРасчетаНалогов.СтавкаНДС;

КонецЕсли;

Если ВариантРасчетаНалогов.СтавкаНПизНоменклатуры = 1 Тогда

СтавкаНП = Товар.СтавкаНП.Получить(ДатаДок);

Иначе

СтавкаНП = ВариантРасчетаНалогов.СтавкаНП;

КонецЕсли;

Цена = глСуммаПриходногоДокумента(ВариантРасчетаНалогов, Цена, 1, Товар.СтавкаНДС.Получить(ДатаДок), Товар, ДатаДок);

Перейти на страницу: 1 2 3 4 5 6 7

Другое по экономике

Анализ использования основных фондов предприятия
Важность проблемы использования основных фондов обусловлена тем, что материальные и финансовые ресурсы народного хозяйства не безграничны, и любые вложения в развитие основных фондов ограничивает возможность потребления. Интенсификация же использования основных фонд ...