Расчет показателей экономической эффективности

Договор = ПолучитьПустоеЗначение("Справочник.Договора");

КонецЕсли;

ВремКатегорияЦен = Клиент.КатегорияЦенПоставщика;

Если ПустоеЗначение(ВремКатегорияЦен) = 1 Тогда

ВремКатегорияЦен = глПользователь.КатегорияЦен;

КонецЕсли;

Если ПустоеЗначение(ВремКатегорияЦен) = 0 Тогда

КатегорияЦен = ВремКатегорияЦен;

КонецЕсли;

КонецЕсли;

Иначе

Договор = ПолучитьПустоеЗначение("Справочник.Договора");

КонецЕсли;

СтарыйКлиент = Клиент;

ОбновитьНадписи();

КонецПроцедуры// ВыборКлиента

//************************************************************

// НАЗНАЧЕНИЕ: вызывается по кнопке кнОснование.

Процедура ВыборОснования()

КонтекстДокумента = глВзятьКонтекст(Контекст);

ОткрытьФормуМодально("Обработка.ОснованиеДокумента", КонтекстДокумента);

ОбновитьНадписи();

ИспользоватьИнформациюОцене();

КонецПроцедуры// ВыборОснования

//************************************************************

// НАЗНАЧЕНИЕ: формирует таблицу для печати документа

Процедура Печать()

Перем ПорядокСекций;

Фирма.ИспользоватьДату(ДатаДок);

Таб= СоздатьОбъект("Таблица");

Если (ВариантРасчетаНалогов.СтавкаНПизНоменклатуры = 0) И

(глПроцентНП(ВариантРасчетаНалогов.СтавкаНП) = 0)

Тогда

ПечататьНП = Нет;

Иначе

ПечататьНП = Да;

КонецЕсли;

Если ПечататьНП =Да Тогда

ВертикальнаяСекция="С_НП";

Иначе

ВертикальнаяСекция="Без_НП";

КонецЕсли;

Таб.ВывестиСекцию("Шапка|"+ВертикальнаяСекция);

Ном= 1;

ВыбратьСтроки();

Пока ПолучитьСтроку() = 1 Цикл

Таб.ВывестиСекцию("Строка|"+ВертикальнаяСекция);

Ном= Ном + 1;

КонецЦикла;

Таб.ВывестиСекцию("Сумма_Итого|"+ВертикальнаяСекция);

Таб.ВывестиСекцию("В_том_числе|"+ВертикальнаяСекция);

Таб.ВывестиСекцию("Сумма_НДС|"+ВертикальнаяСекция);

Таб.ВывестиСекцию("Подвал|"+ВертикальнаяСекция);

Таб.Опции(0, 0, 0, 0, ПарСтрДок);

Таб.Защита(Константа.ФлагЗащитыТаблиц);

Таб.ТолькоПросмотр(1);

Таб.Показать("Печать заказа","");

КонецПроцедуры// Печать

//************************************************************

// Предопределенные процедуры

//************************************************************

Процедура ВводНового(Скопирован)// Предопределенная процедура

Перем ВремКатегорияЦен;

глЗаполнитьШапку(Контекст, Скопирован);

Если Скопирован = 1 Тогда// копирование документа

Возврат;

КонецЕсли;

ДатаДок= РабочаяДата();

Склад= Константа.ОсновнойСклад;

Если ПустоеЗначение(глАктивныйДоговор) = 0 Тогда

Клиент= глАктивныйДоговор.Владелец;

Договор = глАктивныйДоговор;

СтарыйКлиент= Клиент;

КонецЕсли;

Если ПустоеЗначение(Клиент) = 1 Тогда

Клиент= Константа.ОсновнойПоставщик;

КонецЕсли;

Если ПустоеЗначение(Клиент) = 0 Тогда

КатегорияЦен = Клиент.КатегорияЦенПоставщика;

КонецЕсли;

Если ПустоеЗначение(КатегорияЦен) = 1 Тогда

КатегорияЦен= Автор.КатегорияЦен;

КонецЕсли;

Валюта= Константа.ОсновнаяВалютаЗакупки;

Если ПустоеЗначение(Валюта) = 1 Тогда

Валюта= Рубли;

КонецЕсли;

Дата_Курса= ДатаДок;

Курс= глКурсДляВалюты(Валюта, Дата_Курса);

ВыборКлиента();

Если ПустоеЗначение(ВариантРасчетаНалогов) = 1 Тогда

ВариантРасчетаНалогов= Константа.ОсновнойВариантРасчетаНалогов;

КонецЕсли;

ГлУстановкаНомера(Контекст);

КонецПроцедуры// ВводНового

//************************************************************

Процедура ВводНаОсновании(ДокОснование) //Предопределенная процедура

Перейти на страницу: 1 2 3 4 5 6 7

Другое по экономике

Планирование оборотных средств
Задание запас оборотный норматив подготовительный Определить: ) норматив текущего, страхового, подготовительного и общего производственного запаса по видам материалов в натуральном и денежном выражении; ) общую потребность предприятия в оборотн ...