Расчет показателей экономической эффективности

Иначе

Если Константа.ПриИзмененииКоличестваВПриходныхДокументах = 1 Тогда // пересчитывать сумму

Сумма = Цена*Количество;

глРассчитатьНалогиПриходногоДокумента(Контекст);

Иначе // пересчитывать цену

Цена = ?(Количество = 0, 0, Сумма/Количество);

КонецЕсли;

КонецЕсли;

ИначеЕсли ИмяРеквизита = "Единица" Тогда

// сохраним старый коэффициент

ВремКоэфф = Коэффициент;

// заполним коэффициент в документе из единицы

Коэффициент = Единица.Коэффициент;

Если ВремКоэфф <> 0 Тогда

// цена была за другой коэффициент. Пересчетываем

ВремЦена = Цена * Коэффициент / ВремКоэфф;

КонецЕсли;

// если валюта рубли, то нужно округлить цену по коэффициенту

// округления рублевых цен

Если Валюта = Рубли Тогда

ВремЦена = Окр(ВремЦена,Константа.КоэффОкрРублЦены,1);

КонецЕсли;

Цена = ВремЦена;

Сумма = Цена*Количество;

глРассчитатьНалогиПриходногоДокумента(Контекст);

ИначеЕсли ИмяРеквизита = "Цена" Тогда

Сумма = Цена*Количество;

глРассчитатьНалогиПриходногоДокумента(Контекст);

ИначеЕсли ИмяРеквизита = "Сумма" Тогда

глРассчитатьНалогиПриходногоДокумента(Контекст);

Цена = ?(Количество = 0, 0, Сумма/Количество);

ИначеЕсли (ИмяРеквизита = "СтавкаНДС") или (ИмяРеквизита = "СтавкаНП") Тогда

глРассчитатьНалогиПриходногоДокумента(Контекст);

ИначеЕсли (ИмяРеквизита = "НДС") или (ИмяРеквизита = "СуммаНП") Тогда

Всего = глПоказательПриходногоДокумента(Контекст, "СуммаСНалогами");

КонецЕсли;

КонецПроцедуры // Пересчет

//************************************************************

// НАЗНАЧЕНИЕ: возвращает строку, содержащую инфориацию об итогах по колонкам

Процедура Взаиморасчеты()

глПоказатьДолг(Контекст, Клиент, "Закупка");

КонецПроцедуры

//************************************************************

// НАЗНАЧЕНИЕ: выполняет дествия при изменении даты

Процедура ВыборДаты()

глПриИзмененииДатыДокумента(Контекст, СтараяДата);

ОбновитьНадписи();

КонецПроцедуры// ВыборДаты

//************************************************************

// НАЗНАЧЕНИЕ: выполняет дествия при изменении фирмы

Процедура ВыборФирмы()

Перем КонтекстДокумента;

КонтекстДокумента = глВзятьКонтекст(Контекст);

ОткрытьФормуМодально("Обработка.ИнформацияОфирме", КонтекстДокумента);

ОбновитьНадписи();

КонецПроцедуры// ВыборФирмы

//************************************************************

// НАЗНАЧЕНИЕ: вызывается по кнопке кнОплата.

Процедура ВыборОплаты()

Перем КонтекстДокумента;

Перем СтараяКатегорияЦен;

СтараяКатегорияЦен = КатегорияЦен;

КонтекстДокумента = глВзятьКонтекст(Контекст);

ОткрытьФормуМодально("Обработка.ИнформацияОценах", КонтекстДокумента);

Если СтараяКатегорияЦен <> КатегорияЦен Тогда

// изменилась категория цен

// перерисуем

Если ПустоеЗначение(КонтекстПодбора) = 0 Тогда

КонтекстПодбора.Форма.Обновить();

КонецЕсли;

КонецЕсли;

ОбновитьНадписи();

ИспользоватьИнформациюОцене();

КонецПроцедуры// ВыборОплаты

//************************************************************// НАЗНАЧЕНИЕ: вызывается после выбора значения в реквизите Клиент

Процедура ВыборКлиента()

Перем ВремКатегорияЦен;

Если Клиент.Выбран() = 1 Тогда

Если СтарыйКлиент <> Клиент Тогда

Если Константа.ПодставлятьОсновнойДоговор = Да Тогда

// подставим договор по умолчанию

Договор = Клиент.ОсновнойДоговорТорг;

Иначе

// очистим договор

Перейти на страницу: 1 2 3 4 5 6 7

Другое по экономике

Исследование финансовых результатов на примере ООО Элара
Финансовый результат деятельности предприятия характеризуется суммой полученной прибыли. Прибыль отражает финансовый результат от хозяйственной деятельности, полученный предприятием за отчетный период (в случае превышения доходов над расходами). Чем больш ...