Расчет показателей экономической эффективности

ВидимостьКолонкиНП= 0;

КонецЕсли;

КонецЕсли;

Форма.СтавкаНП.Видимость(ВидимостьКолонкиНП);

КонецПроцедуры

//************************************************************

// НАЗНАЧЕНИЕ: возвращает строку, содержащую инфориацию об итогах по колонкам

Функция Итого()

Перем Результат, Всего, СуммаНДС, СуммаНП;

Всего = Итог("Всего");

СуммаНДС = Итог("НДС");

СуммаНП = Итог("СуммаНП");

Результат = ?(Всего= 0, "", " Всего=" + глФРМ(Всего,Валюта, 1))+

?(СуммаНДС= 0, "", " НДС=" + глФРМ(СуммаНДС, Валюта, 1))+

?(СуммаНП= 0, "", " НП=" + глФРМ(СуммаНП,Валюта, 1));

Возврат Результат;

КонецФункции// Итого

//************************************************************

Процедура Пересчет(ИмяРеквизита)

Перем ВремКоэфф, ВремЦена, НовыйТовар;

Если ИмяРеквизита = "Товар" Тогда

Если ПустоеЗначение(Товар) = 1 Тогда

// Удалили товар.

Единица = 0;

Коэффициент = 0;

Цена = 0;

Количество = 0;

Сумма = 0;

СтавкаНДС = 0;

СтавкаНП = 0;

глРассчитатьНалогиПриходногоДокумента(Контекст);

Возврат;

КонецЕсли;

// Определем поменяли ли товар?

НовыйТовар = Нет;

Если ПустоеЗначение(Единица) = 1 Тогда

НовыйТовар = Да;

ИначеЕсли Товар <> Единица.Владелец Тогда

НовыйТовар = Да;

КонецЕсли;

Если НовыйТовар = Нет Тогда

Возврат;

КонецЕсли;

// нужно проверить, чтобы выбранный товар не был набором

Если Товар.ВидТовара = Перечисление.ВидыТоваров.Набор Тогда

Предупреждение("Наборы в документ не добавляются.");

// очистим реквизиты

Товар = ПолучитьПустоеЗначение("Справочник.Номенклатура");

Единица = 0;

Коэффициент = 0;

Цена = 0;

Количество = 0;

Сумма = 0;

СтавкаНДС = 0;

СтавкаНП = 0;

глРассчитатьНалогиПриходногоДокумента(Контекст);

Возврат;

КонецЕсли;

// заполняем единицу

Единица = Товар.ЕдиницаПоУмолчанию;

Коэффициент = Единица.Коэффициент;

// Заполним ставки налогов

Если ВариантРасчетаНалогов.СтавкаНДСизНоменклатуры = 1 Тогда

СтавкаНДС = Товар.СтавкаНДС.Получить(ДатаДок);

Иначе

СтавкаНДС = ВариантРасчетаНалогов.СтавкаНДС;

КонецЕсли;

Если ВариантРасчетаНалогов.СтавкаНПизНоменклатуры = 1 Тогда

СтавкаНП = Товар.СтавкаНП.Получить(ДатаДок);

Иначе

СтавкаНП = ВариантРасчетаНалогов.СтавкаНП;

КонецЕсли;

Если ПустоеЗначение(КатегорияЦен) = 1 Тогда

// нет категории, нет и цены

Возврат;

КонецЕсли;

// вычисляем цену

ЦенаТовара = глВернутьЦену(Товар, КатегорияЦен);

Если ПустоеЗначение(ЦенаТовара) = 1 Тогда

// для товара в категории цены нет

Возврат;

КонецЕсли;

// получим параметры цены

ЦенаЦены= ЦенаТовара.Цена.Получить(ДатаДок);

ВалютаЦены= ЦенаТовара.Валюта.Получить(ДатаДок);

ЕдЦены= ЦенаТовара.Единица.Получить(ДатаДок);

ЦенаЦены = ?(ПустоеЗначение(ЕдЦены.Коэффициент)= 0,ЦенаЦены * Коэффициент / ЕдЦены.Коэффициент,0);

ЦенаЦены = глПересчетДляПодбора(ЦенаЦены,ВалютаЦены,Дата_Курса,Валюта,Курс);

Если Валюта = Рубли Тогда

ЦенаЦены = Окр(ЦенаЦены,Константа.КоэффОкрРублЦены,1);

КонецЕсли;

// Получили цену в нужной валюте с НДС, но без НП (так цены задаются в справочнике)

// Приведем к нужному варианту

Цена = глСуммаПриходногоДокумента(ВариантРасчетаНалогов,

ЦенаЦены,

,

Товар.СтавкаНДС.Получить(ДатаДок),

Товар, ДатаДок);

ИначеЕсли ИмяРеквизита = "Количество" Тогда

Если Сумма = 0 Тогда

Сумма = Количество*Цена;

глРассчитатьНалогиПриходногоДокумента(Контекст);

Перейти на страницу: 1 2 3 4 5 6 7

Другое по экономике

Анализ издержек производства с позиций экономической теории
Анализ деятельности предприятий разных отраслей промышленности показывает, что практически не одно российское предприятие не может продемонстрировать образец организации управления издержками, а количество убыточных предприятий свидетельствует о том, что ...